VS:LDevice GetAccPos3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the 3D position and rotation of the specified accessory.

PROCEDURE LDevice_GetAccPos3D(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
VAR outRotation3D :REAL;
VAR outPosition3D :REAL);
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
    return (outRotation3D, outPosition3D)

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
outRotation3D REAL
outPosition3D REAL

Version

Availability: from Vectorworks 2021