VS:LDevice GetAccPos3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE LDevice_GetAccPos3D(handle:HANDLE; cellIndex:LONGINT; accessoryIndex:LONGINT; VAR outRotation3D:REAL; VAR outPosition3D:REAL);
PROCEDURE LDevice_GetAccPos3D(handle:HANDLE; cellIndex:LONGINT; accessoryIndex:LONGINT; VAR outPosition3D:REAL; VAR outRotation3D:REAL);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
     return (outRotation3D, outPosition3D)
     return (outPosition3D, outRotation3D)
</funcDef>
</funcDef>
</def>
</def>
Line 38: Line 38:
</line>
</line>
<line>
<line>
outRotation3D
outPosition3D
REAL
REAL


</line>
</line>
<line>
<line>
outPosition3D
outRotation3D
REAL
REAL



Latest revision as of 20:14, 11 March 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the 3D position and rotation of the specified accessory.

PROCEDURE LDevice_GetAccPos3D(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
VAR outPosition3D :REAL;
VAR outRotation3D :REAL);
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
    return (outPosition3D, outRotation3D)

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
outPosition3D REAL
outRotation3D REAL

Version

Availability: from Vectorworks 2021