VS:LDevice GetAccPos3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE LDevice_GetAccPos3D(handle:HANDLE; cellIndex:LONGINT; accessoryIndex:LONGINT; VAR outRotation3D:REAL; VAR outPosition3D:REAL);
PROCEDURE LDevice_GetAccPos3D(handle:HANDLE; cellIndex:LONGINT; accessoryIndex:LONGINT; VAR outPosition3D:REAL; VAR outRotation3D:REAL);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
     return (outRotation3D, outPosition3D)
     return (outPosition3D, outRotation3D)
</funcDef>
</funcDef>
</def>
</def>

Revision as of 20:12, 11 March 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the 3D position and rotation of the specified accessory.

PROCEDURE LDevice_GetAccPos3D(
handle :HANDLE;
cellIndex :LONGINT;
accessoryIndex :LONGINT;
VAR outPosition3D :REAL;
VAR outRotation3D :REAL);
def vs.LDevice_GetAccPos3D(handle, cellIndex, accessoryIndex):
    return (outPosition3D, outRotation3D)

Parameters

handle HANDLE
cellIndex LONGINT
accessoryIndex LONGINT
outRotation3D REAL
outPosition3D REAL

Version

Availability: from Vectorworks 2021