VS:KeyDown/ja

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ファンクションキー以外のキーが押された場合、TRUEを返すと同時に押されたキーのASCIIコードを返します。

FUNCTION KeyDown(
VAR asciiCode :LONGINT) : BOOLEAN;
def vs.KeyDown():
    return (BOOLEAN, asciiCode)

Parameters

asciiCode LONGINT 押されたキーのASCIIコード

Return Value

キーが押されていればTRUE

Example

WHILE NOT KeyDown(keyHit) DO
BEGIN
     SysBeep;
     SysBeep;
END;
Message('The key pressed was ',keyHit);
{an annoying example of one use of the KeyDown function}

Version

利用可能バージョン: MiniCAD