VS:IsValidWSSubrowCell

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns whether a specified database subrow cell is in the valid range of displayed subrows.

FUNCTION IsValidWSSubrowCell(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
subrow :INTEGER) : BOOLEAN;
def vs.IsValidWSSubrowCell(worksheet, row, column, subrow):
    return BOOLEAN

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Database row to be queried.
column INTEGER Column to be queried.
subrow INTEGER Index of subrow.

Return Value

A BOOLEAN value indicating whether the subrow cell location is valid.

Remarks

Determines if specified worksheet subrow cell is valid.

WARNING: Because database subrow cells and their contents are dynamically created based on the current database of objects and the current critieria string any return values from this function are not guaranteed to be correct beyond this function call. Use this function carefully and at your own risk.

Version

Availability: from VectorWorks9.0