VS:IsValidWSCell

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns if a specified cell is within the valid range of the referenced worksheet.

FUNCTION IsValidWSCell(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER) : BOOLEAN;
def vs.IsValidWSCell(worksheet, row, column):
    return BOOLEAN

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Row of target cell.
column INTEGER Column of target cell.

Return Value

A BOOLEAN value indicating whether the cell is in the valid range of the worksheet.

Remarks

Determines if specified cell is valid for the specified worksheet.

NOTE: A determination that a cell is valid only means that the specified cell falls within a range of 0 to the current number of worksheet rows and 0 to the current number of worksheet columns. A valid cell does not imply that every worksheet SDK function will accept that cell. The user should always note any specific cell and cell range restrictions of a call they may use.

Version

Availability: from VectorWorks9.0