VS:IsVPGroupContainedObject

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines if specified object is contained within a viewport group, and if so which type of group.

FUNCTION IsVPGroupContainedObject(
objectHandle :HANDLE;
groupType :INTEGER) : BOOLEAN;
def vs.IsVPGroupContainedObject(objectHandle, groupType):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle to object
groupType INTEGER Type of group containing the object: (1 = Crop, 2 = Annotation, 3 = Cache, 4 = Section)

Return Value

true if object is contained within a viewport group

Version

Availability: from VectorWorks11.0