VS:IsTextStyleByClass: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision: vw2015)
(Added comment on the type of objects this is working.)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure IsTextStyleByClass returns whether the class text style is used for the referenced object.</desc>
Procedure IsTextStyleByClass returns whether the class text style is used for the referenced object.
[Dieter@DWorks]: This doesn't seem to be working on polygons. I assume this only works on text objects?
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 16:42, 21 November 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure IsTextStyleByClass returns whether the class text style is used for the referenced object.

[Dieter@DWorks]: This doesn't seem to be working on polygons. I assume this only works on text objects?

FUNCTION IsTextStyleByClass(
objectId :HANDLE) : BOOLEAN;
def vs.IsTextStyleByClass(objectId):
    return BOOLEAN

Parameters

objectId HANDLE handle to object

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetTextStyleRef | VS:GetTextStyleRef | VS:SetTextStyleRefN | VS:GetTextStyleRefN | VS:SetTextStyleByClass | VS:SetTextStyleByClassN | VS:IsTextStyleByClass | VS:IsTextStyleByClassN

VS Functions:

[[VS:SetTextStyleRef]] | [[VS:GetTextStyleRef]] | [[VS:SetTextStyleRefN]] | [[VS:GetTextStyleRefN]] | [[VS:SetTextStyleByClass]] | [[VS:SetTextStyleByClassN]] | [[VS:IsTextStyleByClass]]

| [[VS:IsTextStyleByClassN]]