VS:IsPolyClosed

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Accepts handles to either polylines or polygons. The function returns true if the poly is closed and false if it is open. The return status is independant of hidden / shown sides for polylines. Its return value is based on whether the underlying geometry of the polyline is open or not.

FUNCTION IsPolyClosed(
polyHandle :HANDLE) :BOOLEAN;
def vs.IsPolyClosed(polyHandle):
    return BOOLEAN

Parameters

polyHandle HANDLE

Example

PROCEDURE Example;
BEGIN
   CallTool(-204);
   Message(IsPolyClosed(FSActLayer));
END;
RUN(Example);

Version

Availability: from All Versions

This is drop-in function.