VS:IsPolyClosed: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Accepts handles to either polylines or polygons. The function returns true if the poly is closed and false if it is open. The return status is independant of hidden / shown sides for polylines. Its return value is based on whether the underlying geometry of the polyline is open or not.
Returns true if the specified polyline or polygon is a closed shape, and false otherwise.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IsPolyClosed(polyHandle :HANDLE) :BOOLEAN;
FUNCTION IsPolyClosed(polyHandle:HANDLE) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 29: Line 28:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
BEGIN
  CallTool(-204);
  Message(IsPolyClosed(FSActLayer));
END;
RUN(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:38, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns true if the specified polyline or polygon is a closed shape, and false otherwise.

FUNCTION IsPolyClosed(
polyHandle :HANDLE) : BOOLEAN;
def vs.IsPolyClosed(polyHandle):
    return BOOLEAN

Parameters

polyHandle HANDLE

Version

Availability: from Vectorworks 2014