VS:IsPluginFormat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand)
(expand)
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]]), 2014.09.22: VW 2014, 2015: This routine crashes VW instantly if the passed handle is NIL, be careful. It is weak, for example it fails to recognize a Door format as plug-in format, but will succeed on the Window format.  
([[User:Orso.b.schmid|Orso]]), 2014.09.22: VW 2014, 2015: This routine crashes VW instantly if the passed handle is NIL, be careful.  


It is fully unreliable:
It is unreliable, for example it fails to recognize a Door format as plug-in format, but will succeed on the Window format.
* generic objects with attached format (normal format in the Resource Browser) will be mistakenly recognized as parametric (obj. type 48), while their record definition (obj. type 47) won't.
* generic objects with attached format (normal format in the Resource Browser) will be mistakenly recognized as parametric (type 48), while their record definition (type 47) won't.
* on the opposite, parametric objects often won't be recognized as parametric (obj. type 48), while their record definition (obj. type 47) will .
* on the opposite, parametric objects often won't be recognized as parametric (type 48), while their record definition (type 47) will .


It seems to succeed to parse clean VS objects, but there are loads of shipped objects where this fails, for example: Spiral, Callout, North Arrow, Landscape Area, Grade Tool, Parking along Path, Parking Area, Roadway Tee, Guardrail (Curved), Graticule, Adjacent Matrix, Stacking Diagram, Space Link, Slab, Window Wall (Curved), Column, Pilaster, CW-Stair, Simple Elevator, Chain Extrude, Renderworks Camera, Human Figure, Handrail (Curved), Toilet Stall, Ceiling Grid, Seating Count, Table and Chairs, Slope Dimension, Stipple, Reference Marker, Revision Marker, Linear Marker, Repetitive Unit, and so on...
It seems to succeed while parsing clean third-party VS parametric objects, but there are loads of shipped objects where this fails - also VS not only SDK, for example: Spiral, Callout, North Arrow, Landscape Area, Grade Tool, Parking along Path, Parking Area, Roadway Tee, Guardrail (Curved), Graticule, Adjacent Matrix, Stacking Diagram, Space Link, Slab, Window Wall (Curved), Column, Pilaster, CW-Stair, Simple Elevator, Chain Extrude, Renderworks Camera, Human Figure, Handrail (Curved), Toilet Stall, Ceiling Grid, Seating Count, Table and Chairs, Slope Dimension, Stipple, Reference Marker, Revision Marker, Linear Marker, Repetitive Unit, and so on...
</remark>
</remark>



Revision as of 10:37, 22 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines if the format node is used for the parameters of a plug-in object, plug-in tool or plug-in menu command.

FUNCTION IsPluginFormat(
theFormat :HANDLE) : BOOLEAN;
def vs.IsPluginFormat(theFormat):
    return BOOLEAN

Parameters

theFormat HANDLE Handle to the format node in question.

Return Value

Returns true if format is used by a plug-in and false if it is a regular format that may have been created by the user.

Remarks

(Orso), 2014.09.22: VW 2014, 2015: This routine crashes VW instantly if the passed handle is NIL, be careful.

It is unreliable, for example it fails to recognize a Door format as plug-in format, but will succeed on the Window format.

  • generic objects with attached format (normal format in the Resource Browser) will be mistakenly recognized as parametric (type 48), while their record definition (type 47) won't.
  • on the opposite, parametric objects often won't be recognized as parametric (type 48), while their record definition (type 47) will .

It seems to succeed while parsing clean third-party VS parametric objects, but there are loads of shipped objects where this fails - also VS not only SDK, for example: Spiral, Callout, North Arrow, Landscape Area, Grade Tool, Parking along Path, Parking Area, Roadway Tee, Guardrail (Curved), Graticule, Adjacent Matrix, Stacking Diagram, Space Link, Slab, Window Wall (Curved), Column, Pilaster, CW-Stair, Simple Elevator, Chain Extrude, Renderworks Camera, Human Figure, Handrail (Curved), Toilet Stall, Ceiling Grid, Seating Count, Table and Chairs, Slope Dimension, Stipple, Reference Marker, Revision Marker, Linear Marker, Repetitive Unit, and so on...

Version

Availability: from VectorWorks 11.0