VS:IsPlanarObj

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

FUNCTION IsPlanarObj(
object :HANDLE;
VAR refID :LONGINT) : BOOLEAN;
def vs.IsPlanarObj(object):
    return (BOOLEAN, refID)

Parameters

object HANDLE Object to test
refID LONGINT If object is planar, returns the planar refID of its plane

Remarks

This function always seems to return 0 for refID, no matter which plane the object being tested is located.

Use GetPlanarRef instead to find the planar refID of a given planar object.

Version

Availability: from Vectorworks 2016