VS:IsObjectFlipped

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function IsObjectFlipped returns the flip orientation of the specified 3D object. The function returns TRUE if the object is currently flipped.

This function works for sweeps, extrudes, multiple extrudes, symbols, solids, layer references, and plug-in objects.

FUNCTION IsObjectFlipped(
h :HANDLE) : BOOLEAN;
def vs.IsObjectFlipped(h):
    return BOOLEAN

Parameters

h HANDLE Handle to object.

Remarks

Returns true if the object is currently flipped. Works for sweeps, extrudes, mextrudes, symbols, solids, layer refs, and plug-in objects

[sd 8/19/98]

Example

VectorScript

FUNCTION ObjFlippedInWall(objH, wallH :HANDLE) :BOOLEAN;
BEGIN
ObjFlippedInWall := ((Trunc(GetSymRot(objH)) <> Trunc(HAngle(wallH))) = IsObjectFlipped(objH)); 
END;

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:IsFlipped

VS Functions: [[VS:IsFlipped]]