VS:IsLWByClass

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function IsLWByClass returns whether a class line weight is used for the referenced object.

FUNCTION IsLWByClass(
h :HANDLE) : BOOLEAN;
def vs.IsLWByClass(h):
    return BOOLEAN

Parameters

h HANDLE Handle to object.

Remarks

Returns an indication of whether the class line weight is used for the object referenced by h.

[sd 8/19/98]

Example

VectorScript

PROCEDURE Example;
VAR
symDefHandle, h :HANDLE;

PROCEDURE AlertMe;
BEGIN
Message(GetSDName(symDefHandle));
SetSelect(h);
END;

BEGIN
DSelectAll;
ClrMessage;
symDefHandle := FSymDef;
WHILE symDefHandle <> NIL DO BEGIN
h := FInSymDef(symDefHandle);
WHILE h <> NIL DO BEGIN
IF IsLWByClass(h) THEN AlertMe;
h := NextObj(h);
END;
symDefHandle := NextObj(symDefHandle);
END;
END;
RUN(Example);

Python


Version

Availability: from VectorWorks8.0