VS:IsGeoreferenced

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Check if the layer is georeferenced. Pass NIL to check the document.

FUNCTION IsGeoreferenced(
hLayer :HANDLE) : BOOLEAN;
def vs.IsGeoreferenced(hLayer):
    return BOOLEAN

Parameters

hLayer HANDLE Pass NIL for Vectorscript and None for Python if you want to manage the document.

Example

VectorScript

PROCEDURE Test;
var
isGeoref: BOOLEAN;
BEGIN
RemoveGeoref(NIL);
isGeoref := IsGeoreferenced(NIL);
if (isGeoref) then 
	AlrtDialog('The file is georeferenced.')
else
	AlrtDialog('The file is not georeferenced.');
end;
run(Test);

Python

vs.RemoveGeoref(None)
isGeoref	= vs.IsGeoreferenced(None)
if isGeoref:
	vs.AlrtDialog('The file is georeferenced.')
else:
	vs.AlrtDialog('The file is not georeferenced.')

Version

Availability: from Vectorworks 2012