VS:IsFlipped

From Vectorworks Developer
Revision as of 21:46, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of objects meeting the criteria that are flipped.

FUNCTION IsFlipped(
c :CRITERIA) : REAL;
def vs.IsFlipped(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns true? if the object matching the given criteria (such as a symbol is flipped. Only certain types of objects can be flipped.

The change to criteria for this seems weird; does it accumulate the flipped states of the objects matching the criteria and return the sum?

Example

VectorScript

PROCEDURE CountFlippedDoorSymbols;
BEGIN
Message(IsFlipped(S='*Door*'));
END;
RUN(CountFlippedDoorSymbols);

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:IsObjectFlipped

VS Functions: [[VS:IsObjectFlipped]]