VS:IsFlipped: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the number of objects meeting the criteria that are flipped.

FUNCTION IsFlipped(
c :CRITERIA) : REAL;
def vs.IsFlipped(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns true? if the object matching the given criteria (such as a symbol is flipped. Only certain types of objects can be flipped.

The change to criteria for this seems weird; does it accumulate the flipped states of the objects matching the criteria and return the sum?

Example

VectorScript

PROCEDURE CountFlippedDoorSymbols;
BEGIN
Message(IsFlipped(S='*Door*'));
END;
RUN(CountFlippedDoorSymbols);

Python


Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:IsObjectFlipped

VS Functions: [[VS:IsObjectFlipped]]