VS:IsCurtainWall

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use to check whether wall is being used as a curtain wall.

FUNCTION IsCurtainWall(
hWall :HANDLE) : BOOLEAN;
def vs.IsCurtainWall(hWall):
    return BOOLEAN

Parameters

hWall HANDLE Handle to a wall object to check for curtain wall status

Return Value

Will return TRUE if hWall is set to be a curtain wall.

Will retrun FALSE if hWall is not a wall node or the wall is not set to be a curtain wall.

Version

Availability: from Vectorworks 2014