VS:IntersectSolid

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function IntersectSolid creates a new solid intersection object from the referenced source objects.

Table - Solids Operation Result Codes
Operation Result Result Code
Success 0
Null geometry error 1
Geometry error 2
Out of memory error 4
Bad group error 5
Invalid object type 6
Bad input 20
FUNCTION IntersectSolid(
obj1 :HANDLE;
obj2 :HANDLE;
VAR newSolid :HANDLE) : INTEGER;
def vs.IntersectSolid(obj1, obj2):
    return (INTEGER, newSolid)

Parameters

obj1 HANDLE Handle to source object for intersect operation.
obj2 HANDLE Handle to source object for intersect operation.
newSolid HANDLE Handle to resultant object from intersect operation.

Version

Availability: from MiniCAD 7.0