VS:InsertSymbol/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁の中の指定した位置にシンボルを配置します。

PROCEDURE InsertSymbol(
offsetDistance :REAL)Coordinate); heightDistance:REAL (Coordinate); flipped:BOOLEAN; right:BOOLEAN; capped:BOOLEAN; symbolName:STRING);
def vs.InsertSymbol(offsetDistance, heightDistance, flipped, right, capped, symbolName):
    return None

Parameters

offsetDistance REAL (Coordinate) 壁の始点からの距離
heightDistance REAL (Coordinate) 挿入位置の高さ
flipped BOOLEAN シンボルを反転する場合はTRUE
right BOOLEAN 右側に挿入する場合はTRUE
capped BOOLEAN 挿入位置の壁を閉じる場合はTRUE
symbolName STRING シンボルの名前

Example

MoveTo(3,1);
WallTo(5',5');
InsertSymbol(1',False,False,True,'Door');
{inserts the symbol 'Door' at 1' from the start point of the last wall segment}

Version

利用可能バージョン: MiniCAD4.0

See Also

関連関数:

VS:AddSymToWall | VS:AddSymToWallEdge

関連関数:

[[VS:AddSymToWall]]

| [[VS:AddSymToWallEdge]]