VS:InsertPropClassOrLayerItem

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts a class or layer item in the proposed section of a Class, Design Layer, or Sheet Layer Layout Manager Pull Down.

Replaces InsertProposedClassOrLayerItem

FUNCTION InsertPropClassOrLayerItem(
dialogID :LONGINT;
controlID :LONGINT;
strLabel :STRING;
imageSpecifier :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.InsertPropClassOrLayerItem(dialogID, controlID, strLabel, imageSpecifier):
    return BOOLEAN

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The control identifier.
strLabel STRING Text for the label of the Pull Down.
imageSpecifier DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012