VS:InsertNewDLComponent

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts a new component before index in the Double Line Preferences.

FUNCTION InsertNewDLComponent(
beforeIndex :INTEGER;
widthDistance :REAL;
fill :LONGINT;
penWeightLeft :INTEGER;
penWeightRight :INTEGER;
penStyleLeft :INTEGER;
penStyleRight :INTEGER) : BOOLEAN;
def vs.InsertNewDLComponent(beforeIndex, widthDistance, fill, penWeightLeft, penWeightRight, penStyleLeft, penStyleRight):
    return BOOLEAN

Parameters

beforeIndex INTEGER The index before which to insert the new component.
widthDistance REAL The width of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative ref numbers for hatches.
penWeightLeft INTEGER The pen weight of the component's left line.
penWeightRight INTEGER The pen weight of the component's right line.
penStyleLeft INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
penStyleRight INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Remarks

(6-27-06 CJG)

Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:DeleteDLComponent

VS Functions: [[VS:DeleteDLComponent]]