VS:InsertNewComponent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts a new component in an object.

FUNCTION InsertNewComponent(
object :HANDLE;
beforeComponentIndex :INTEGER;
width :REAL;
fill :LONGINT;
leftPenWeight :INTEGER;
rightPenWeight :INTEGER;
leftPenStyle :INTEGER;
rightPenStyle :INTEGER) : BOOLEAN;
def vs.InsertNewComponent(object, beforeComponentIndex, width, fill, leftPenWeight, rightPenWeight, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
beforeComponentIndex INTEGER The index before which to insert the new component.
width REAL The width of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative ref numbers for hatches.
leftPenWeight INTEGER The pen weight of the component's left line.
rightPenWeight INTEGER The pen weight of the component's right line.
leftPenStyle INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:DeleteComponent

VS Functions: [[VS:DeleteComponent]]