VS:InsertImagePopupResource: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts the indicated item of the specified resource list into the indicated image popup and returns the image popup index of the inserted item.

FUNCTION InsertImagePopupResource(
dialogID :LONGINT;
componentID :LONGINT;
listID :LONGINT;
index :LONGINT) : LONGINT;
def vs.InsertImagePopupResource(dialogID, componentID, listID, index):
    return LONGINT

Parameters

dialogID LONGINT index to the dialog layout that contains the image popup component.
componentID LONGINT index to a specific image popup component.
listID LONGINT an ID for a resource list created by the BuildResourceList function.
index LONGINT an index into the list.

Example

VectorScript

{ Add all items in the resource list to the image popup. }
for index:=1 to numItems do
index := InsertImagePopupResource(dialogID, kImagePopupID, listID,   index);

Python


Version

Availability: from VectorWorks12.0