VS:InsertGradientSliderSegment

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Inserts a new segment into the gradient slider and initializes its data to the specified values.

FUNCTION InsertGradientSliderSegment(
dialogID :LONGINT;
componentID :LONGINT;
spotPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT) : INTEGER;
def vs.InsertGradientSliderSegment(dialogID, componentID, spotPosition, red, green, blue):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.
spotPosition REAL Position of the segment's color marker relative to left-most point of the slider. The value should be >= 0.0 and <= 1.0, which represents a percentage distance across the slider.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.

Return Value

Returns index to new segment.

Example

VectorScript

segmentIndex := InsertGradientSliderSegment(dialogID, componentID, 0.4, 255, 255, 255);

Python


Version

Availability: from VectorWorks10.0