VS:InsertGradientSliSeg

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

FUNCTION InsertGradientSliSeg(
dialogID :LONGINT;
componentID :LONGINT;
spotPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT;
opacity :INTEGER) : INTEGER;
def vs.InsertGradientSliSeg(dialogID, componentID, spotPosition, red, green, blue, opacity):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.
spotPosition REAL Position of the segment's color marker relative to left-most point of the slider. The value should be >= 0.0 and <= 1.0, which represents a percentage distance across the slider.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.
opacity INTEGER Opacity for the color at the spot position.

Return Value

Returns index to new segment.

Example

segmentIndex := InsertGradientSliSeg(dialogID, componentID, 0.4, 255, 255, 255, 100);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetGradientSlider | VS:SetGradientSlider

VS Functions:

[[VS:GetGradientSlider]]

| [[VS:SetGradientSlider]]