VS:InsertGradientSegment/ja

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

グラデーションに新しい変化位置を挿入し、そのデータを指定した値で初期化します。


変化位置は1つの変化点と、そのすぐ右にある1つの変化の中心点から構成されています。

FUNCTION InsertGradientSegment(
gradient :HANDLE;
spotPosition :REAL;
midpointPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT) : INTEGER;
def vs.InsertGradientSegment(gradient, spotPosition, midpointPosition, red, green, blue):
    return INTEGER

Parameters

gradient HANDLE グラデーションのハンドル
spotPosition REAL 変化点の位置(0.0以上1.0以下)
midpointPosition REAL 変化の中心点の位置(0.0以上1.0以下)
red LONGINT 変化点の色の赤成分(0以上255以下)
green LONGINT 変化点の色の緑成分(0以上255以下)
blue LONGINT 変化点の色の青成分(0以上255以下)

Return Value

新しく作成された変化位置の番号を返します。作成できなかった場合は0を返します。

Example

index := InsertGradientSegment(gradientHandle, 0.35, 0.4, 255, 255, 255);
{ inserts a white color spot at position, 0.35, with a midpoint position of 0.4 }

Version

利用可能バージョン: VectorWorks10.0