VS:InsertGradientData/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

グラデーションに新しい変化位置を挿入し、そのデータを指定した値で初期化します。

FUNCTION InsertGradientData(
gradient :HANDLE;
spotPosition :REAL;
midpointPosition :REAL;
red :LONGINT;
green :LONGINT;
blue :LONGINT;
opacity :INTEGER) : INTEGER;
def vs.InsertGradientData(gradient, spotPosition, midpointPosition, red, green, blue, opacity):
    return INTEGER

Parameters

gradient HANDLE グラデーションのハンドル
spotPosition REAL 変化点の位置(0.0以上1.0以下)
midpointPosition REAL 変化の中心点の位置(0.0以上1.0以下)
red LONGINT 変化点の色の赤成分(0以上255以下)
green LONGINT 変化点の色の緑成分(0以上255以下)
blue LONGINT 変化点の色の青成分(0以上255以下)
opacity INTEGER 変化点の色の不透明度

Return Value

新しく作成された変化位置の番号を返します。作成できなかった場合は0を返します。
注:変化位置の番号は1から始まります。

Example

index := InsertGradientData(gradientHandle, 0.35, 0.4, 255, 255, 255, 100);
{ inserts a white color spot at position, 0.35, with a midpoint position of 0.4; 100 is max opacity (i.e. opaque) }

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetGradientDataN | VS:SetGradientDataN

VS Functions:

[[VS:GetGradientDataN]]

| [[VS:SetGradientDataN]]