VS:Insert: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Insert will insert the specified string into a destination string.

PROCEDURE Insert(
source :DYNARRAY[] of CHAR;
VAR dest :DYNARRAY[] of CHAR;
index :INTEGER);
def vs.Insert(source, index):
    return dest

Parameters

source DYNARRAY[] of CHAR String to be inserted.
dest DYNARRAY[] of CHAR Destination string.
index INTEGER Position where string is to be inserted.

Example

VectorScript

theStr:='sample';
originalStr:='A string';
Insert(theStr,originalStr,3);
{inserts 'sample' into the target string}

Python


Version

Availability: from All Versions