VS:ImportImageFileN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Import the specified image file as an Image object in Vectorworks. This function allows controlling the options when importing the image.

FUNCTION ImportImageFileN(
filePath :DYNARRAY[] of CHAR;
importPt :REAL;
mode :INTEGER) : HANDLE;
def vs.ImportImageFileN(filePath, importPt, mode):
    return HANDLE

Parameters

filePath DYNARRAY[] of CHAR Import file path.
importPt REAL The import location.
mode INTEGER Import mode: 0 - import using import option dialog; 1 - import using the last options. If the call was never made with option dialog, then the first time it will show the options dialog.

Return Value

Return the imported image handle, or NIL if the import failed.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:ImportImageFile

VS Functions: [[VS:ImportImageFile]]