VS:ImportImageFileN

From Vectorworks Developer
Revision as of 14:46, 21 September 2014 by CBM-c- (talk | contribs) (fix various typos)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Import the specified image file as an Image object in Vectorworks. This function allows controlling the options when importing the image.

FUNCTION ImportImageFileN(
filePath :DYNARRAY[] of CHAR;
importPt :REAL;
mode :INTEGER) : HANDLE;
def vs.ImportImageFileN(filePath, importPt, mode):
    return HANDLE

Parameters

filePath DYNARRAY[] of CHAR Import file path.
importPt REAL The import location.
mode INTEGER Import mode: 0 - import using import option dialog; 1 - import using the last options. If the call was never made with option dialog, then the first time it will show the options dialog.

Return Value

Return the imported image handle, or NIL if the import failed.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:ImportImageFile

VS Functions: [[VS:ImportImageFile]]