VS:IFC SetPsetProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(No difference)

Revision as of 15:46, 7 August 2009

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function sets a value to the selected property of the selected pset.

FUNCTION IFC_SetPsetProp(
hObject  : HANDLE;
inStrPsetName  : STRING;
inStrPropName  : STRING;
inStrPropValue  : STRING) : BOOLEAN;
def vs.IFC_SetPsetProp(hObject, inStrPsetName, inStrPropName, inStrPropValue):
    return BOOLEAN

Parameters

hObject HANDLE
inStrPsetName STRING
inStrPropName STRING
inStrPropValue STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the pset or property;

Remarks

None.

Example

Assume we have a wall and we want in export to be marked as load-bearing, non-combustible and to put a reference ‘IW-01’, also we want to set thermal transmit-tance value of 0.5 – we need to attach Pset_WallCommon and set its properties ( LoadBearing, Combustible, Reference, ThermalTransmittance) as needed:

IFC_SetIFCEntity(hWall, 'IfcWallStandardCase');
IFC_AttachPset(hWall, 'Pset_WallCommon');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'LoadBearing', '1');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'Combustible', '0');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'Reference', 'IW-01');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'ThermalTransmittance', '0.5');

Version

Availability: 2010