VS:IFC SetPsetProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This function sets a value to the selected property of the selected pset.
Sets the value of a selected property from a property set</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IFC_SetPsetProp(hObject: HANDLE; inStrPsetName: STRING; inStrPropName: STRING; inStrPropValue: STRING) : BOOLEAN;
FUNCTION IFC_SetPsetProp(hObject:HANDLE; inStrPsetName:STRING; inStrPropName:STRING; inStrPropValue:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 44: Line 43:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the pset or property;
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
None.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
Assume we have a wall and we want in export to be marked as load-bearing, non-combustible and to put a reference ‘IW-01’, also we want to set thermal transmit-tance value of 0.5 – we need to attach Pset_WallCommon and set its properties ( LoadBearing, Combustible, Reference, ThermalTransmittance) as needed:
<code lang="pas">
IFC_SetIFCEntity(hWall, 'IfcWallStandardCase');
IFC_AttachPset(hWall, 'Pset_WallCommon');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'LoadBearing', '1');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'Combustible', '0');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'Reference', 'IW-01');
IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'ThermalTransmittance', '0.5');
</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: 2010
Availability: from Vectorworks 2014


</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of a selected property from a property set

FUNCTION IFC_SetPsetProp(
hObject :HANDLE;
inStrPsetName :STRING;
inStrPropName :STRING;
inStrPropValue :STRING) : BOOLEAN;
def vs.IFC_SetPsetProp(hObject, inStrPsetName, inStrPropName, inStrPropValue):
    return BOOLEAN

Parameters

hObject HANDLE
inStrPsetName STRING
inStrPropName STRING
inStrPropValue STRING

Version

Availability: from Vectorworks 2014