VS:IFC SetIFCEntity

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates and attaches to hObject an IFC Record with the given IFC entity.

FUNCTION IFC_SetIFCEntity(
hObject  : HANDLE;
inStrIfcName  : STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE
inStrIfcName STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name

Remarks

Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one

Example

Assume we have an object, which we want to be exported as furniture:

IFC_SetIFCEntity(hObject, 'IfcFurnishingElement');

Version

Availability: 2010