VS:IFC SetIFCEntity

From Vectorworks Developer
Revision as of 15:42, 7 August 2009 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates and attaches to hObject an IFC Record with the given IFC entity.

FUNCTION IFC_SetIFCEntity(
hObject  : HANDLE;
inStrIfcName  : STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE
inStrIfcName STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name

Remarks

Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one

Example

Assume we have an object, which we want to be exported as furniture:

IFC_SetIFCEntity(hObject, 'IfcFurnishingElement');

Version

Availability: 2010