VS:IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(5 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This function creates and attaches to hObject an IFC Record with the given IFC entity.
This function creates and attaches to hObject an IFC Record with the given IFC entity.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IFC_SetIFCEntity(hObject: HANDLE; inStrIfcName: STRING) : BOOLEAN;
FUNCTION IFC_SetIFCEntity(hObject:HANDLE; inStrIfcName:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 22: Line 21:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
<line>
hObject
hObject
HANDLE
HANDLE
Handle to object
</line>


</line>
<line>
<line>
inStrIfcName
inStrIfcName
STRING
STRING
Name of the IFC entity
</line>


</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.


-----------------------------------------------------------------------------------------------------------
Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.</return>
<return>
TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark></remark>
Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
Assume we have an object, which we want to be exported as furniture:
Assume we have an object, which we want to be exported as furniture:
==== VectorScript ====
<code lang="pas">
<code lang="pas">
IFC_SetIFCEntity(hObject, 'IfcFurnishingElement');
IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)
</code>
</code>
</sample>
</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: 2010
Availability: from Vectorworks 2014


</version>
</version>


-----------------------------------------------------------------------------------------------------------
</vwDoc>
<seeAlso>
</seeAlso>


</vwDoc>


[[Category:VS Function Reference|IFC_SetIFCEntity]]
[[Category:VS Function Reference|IFC_SetIFCEntity]]
[[Category:VS Function Reference:IFC|IFC_SetIFCEntity]]
[[Category:VS Function Reference:IFC|IFC_SetIFCEntity]]

Latest revision as of 19:02, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates and attaches to hObject an IFC Record with the given IFC entity.

FUNCTION IFC_SetIFCEntity(
hObject :HANDLE;
inStrIfcName :STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object
inStrIfcName STRING Name of the IFC entity

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.

Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.

Example

Assume we have an object, which we want to be exported as furniture:

VectorScript

IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);

Python

ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)

Version

Availability: from Vectorworks 2014