VS:IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets IFC entity type</desc>
This function creates and attaches to hObject an IFC Record with the given IFC entity.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 21: Line 21:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
<line>
hObject
hObject
HANDLE
HANDLE
Handle to object
</line>


</line>
<line>
<line>
inStrIfcName
inStrIfcName
STRING
STRING
Name of the IFC entity
</line>


</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.
Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 38: Line 46:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
Assume we have an object, which we want to be exported as furniture:
==== VectorScript ====
<code lang="pas">
IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 50: Line 68:


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|IFC_SetIFCEntity]]
[[Category:VS Function Reference|IFC_SetIFCEntity]]
[[Category:VS Function Reference:IFC|IFC_SetIFCEntity]]
[[Category:VS Function Reference:IFC|IFC_SetIFCEntity]]

Latest revision as of 19:02, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates and attaches to hObject an IFC Record with the given IFC entity.

FUNCTION IFC_SetIFCEntity(
hObject :HANDLE;
inStrIfcName :STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object
inStrIfcName STRING Name of the IFC entity

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.

Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.

Example

Assume we have an object, which we want to be exported as furniture:

VectorScript

IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);

Python

ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)

Version

Availability: from Vectorworks 2014