VS:IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets IFC entity type</desc>
This function creates and attaches to hObject an IFC Record with the given IFC entity.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 21: Line 21:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
<line>
hObject
hObject
HANDLE
HANDLE
Handle to object
</line>


</line>
<line>
<line>
inStrIfcName
inStrIfcName
STRING
STRING
Name of the IFC entity
</line>


</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.
 
Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
Assume we have an object, which we want to be exported as furniture:
==== VectorScript ====
<code lang="pas">
IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:03, 27 October 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function creates and attaches to hObject an IFC Record with the given IFC entity.

FUNCTION IFC_SetIFCEntity(
hObject :HANDLE;
inStrIfcName :STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object
inStrIfcName STRING Name of the IFC entity

Remarks

Return Values

TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name.

Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one.

Example

Assume we have an object, which we want to be exported as furniture:

VectorScript

IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’);

Python

ok = vs.IFC_SetIFCEntity(hObject, ‘IfcFurnishingElement’)

Version

Availability: from Vectorworks 2014