VS:IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This function creates and attaches to hObject an IFC Record with the given IFC entity.
Sets IFC entity type</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IFC_SetIFCEntity(hObject: HANDLE; inStrIfcName: STRING) : BOOLEAN;
FUNCTION IFC_SetIFCEntity(hObject:HANDLE; inStrIfcName:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 34: Line 33:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
TRUE on success, FALSE indicates failure – incorrect handle or IFC entity name
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
Note that, if an IFC record, attached to that handle already exists, it will be deleted, prior to attaching the new one
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
Assume we have an object, which we want to be exported as furniture:
<code lang="pas">
IFC_SetIFCEntity(hObject, 'IfcFurnishingElement');
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: 2010
Availability: from Vectorworks 2014


</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets IFC entity type

FUNCTION IFC_SetIFCEntity(
hObject :HANDLE;
inStrIfcName :STRING) : BOOLEAN;
def vs.IFC_SetIFCEntity(hObject, inStrIfcName):
    return BOOLEAN

Parameters

hObject HANDLE
inStrIfcName STRING

Version

Availability: from Vectorworks 2014