VS:IFC SetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This function sets a value to the selected property of the IFC entity.
Sets the value of a selected property from the IFC entity</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IFC_SetEntityProp(hObject: HANDLE; inStrPropName: STRING; inStrPropValue: STRING) : BOOLEAN;
FUNCTION IFC_SetEntityProp(hObject:HANDLE; inStrPropName:STRING; inStrPropValue:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the property;
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
Note that, all of the mandatory properties of the IFC entity must be given, otherwise IFC exported file will be not valid (regarding the specification). Also, all properties with enumeration value must be set, even if they are optional - if not sure about the value, USERDEFINED or NOTDEFINED can be supplied – there are a lot of known issues with existing software implementations in case of missing values.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
Assume we have an extrude, that we want to be exported as a slab. IfcSlab has a property with enumeration value (“PredefinedType”), so it’s necessary to be set:
<code lang="pas">
IFC_SetIFCEntity(hExtrude, 'IfcSlab');
IFC_SetEntityProp(hExtrude, 'PredefinedType', 'BASESLAB');
</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: 2010
Availability: from Vectorworks 2014


</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of a selected property from the IFC entity

FUNCTION IFC_SetEntityProp(
hObject :HANDLE;
inStrPropName :STRING;
inStrPropValue :STRING) : BOOLEAN;
def vs.IFC_SetEntityProp(hObject, inStrPropName, inStrPropValue):
    return BOOLEAN

Parameters

hObject HANDLE
inStrPropName STRING
inStrPropValue STRING

Version

Availability: from Vectorworks 2014