VS:IFC ImportWithUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 19: Line 19:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return></return>
<return>TRUE on success, FALSE indicates failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 25: Line 25:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
 
BEGIN
ok := IFC_ImportWithUI();
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_ImportWithUI()
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:17, 20 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file with user interface

PROCEDURE IFC_ImportWithUI;
def vs.IFC_ImportWithUI():
    return None

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;

BEGIN
	ok := IFC_ImportWithUI();
END;

RUN(Test);

Python

ok = vs.IFC_ImportWithUI()

Version

Availability: from Vectorworks 2014