VS:IFC ImportWithUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (fix typo)
 
(3 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Imports IFC file with user interface</desc>
Imports IFC file using the IFC Import dialog.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 17: Line 17:
</funcDef>
</funcDef>
</def>
</def>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 22: Line 25:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
 
BEGIN
ok := IFC_ImportWithUI();
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_ImportWithUI()
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 11:30, 11 June 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file using the IFC Import dialog.

PROCEDURE IFC_ImportWithUI;
def vs.IFC_ImportWithUI():
    return None

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;

BEGIN
	ok := IFC_ImportWithUI();
END;

RUN(Test);

Python

ok = vs.IFC_ImportWithUI()

Version

Availability: from Vectorworks 2014