VS:IFC ImportNoUI

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file without showing any dialog.

PROCEDURE IFC_ImportNoUI(
strFilePath :STRING);
def vs.IFC_ImportNoUI(strFilePath):
    return None

Parameters

strFilePath STRING File path.

Return Value

There is no return value.

Example

VectorScript

PROCEDURE Test;

BEGIN
	IFC_ImportNoUI('D:\Import\Test.ifc');
END;

RUN(Test);

Python

vs.IFC_ImportNoUI('D:\Import\Test.ifc')

Version

Availability: from Vectorworks 2014