VS:IFC ImportNoUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Imports IFC file, silent mode</desc>
Imports IFC file without showing any dialog.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 24: Line 24:
strFilePath
strFilePath
STRING
STRING
File path.


</line>
</line>
Line 30: Line 31:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return></return>
<return>
There is no return value.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 07:37, 14 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file without showing any dialog.

PROCEDURE IFC_ImportNoUI(
strFilePath :STRING);
def vs.IFC_ImportNoUI(strFilePath):
    return None

Parameters

strFilePath STRING File path.

Return Value

There is no return value.

Example

VectorScript

PROCEDURE Test;

BEGIN
	ok := IFC_ImportNoUI('D:\Import\Test.ifc');
END;

RUN(Test);

Python

ok = vs.IFC_ImportNoUI('D:\Import\Test.ifc')

Version

Availability: from Vectorworks 2014