VS:IFC ImportNoUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Imports IFC file, silent mode</desc>
Imports IFC file without showing any dialog.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 24: Line 24:
strFilePath
strFilePath
STRING
STRING
File path.


</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
There is no return value.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 33: Line 39:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
 
BEGIN
IFC_ImportNoUI('D:\Import\Test.ifc');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
vs.IFC_ImportNoUI('D:\Import\Test.ifc')
</code>
</sample>
 


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:40, 28 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file without showing any dialog.

PROCEDURE IFC_ImportNoUI(
strFilePath :STRING);
def vs.IFC_ImportNoUI(strFilePath):
    return None

Parameters

strFilePath STRING File path.

Return Value

There is no return value.

Example

VectorScript

PROCEDURE Test;

BEGIN
	IFC_ImportNoUI('D:\Import\Test.ifc');
END;

RUN(Test);

Python

vs.IFC_ImportNoUI('D:\Import\Test.ifc')

Version

Availability: from Vectorworks 2014