VS:IFC ImportNoUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 45: Line 45:


BEGIN
BEGIN
ok := IFC_ImportNoUI('D:\Import\Test.ifc');
IFC_ImportNoUI('D:\Import\Test.ifc');
END;
END;


Line 52: Line 52:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
ok = vs.IFC_ImportNoUI('D:\Import\Test.ifc')
vs.IFC_ImportNoUI('D:\Import\Test.ifc')
</code>
</code>
</sample>
</sample>

Latest revision as of 08:40, 28 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports IFC file without showing any dialog.

PROCEDURE IFC_ImportNoUI(
strFilePath :STRING);
def vs.IFC_ImportNoUI(strFilePath):
    return None

Parameters

strFilePath STRING File path.

Return Value

There is no return value.

Example

VectorScript

PROCEDURE Test;

BEGIN
	IFC_ImportNoUI('D:\Import\Test.ifc');
END;

RUN(Test);

Python

vs.IFC_ImportNoUI('D:\Import\Test.ifc')

Version

Availability: from Vectorworks 2014