VS:IFC GetPsetProp2

From Vectorworks Developer
Revision as of 19:25, 12 September 2017 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the property value, its type and if the value comes from mapping or by instance.

FUNCTION IFC_GetPsetProp2(
hObject :HANDLE;
pSetName :STRING;
propertyName :STRING;
VAR outPropValue :STRING;
VAR outType :INTEGER;
VAR outMap :INTEGER) : BOOLEAN;
def vs.IFC_GetPsetProp2(hObject, pSetName, propertyName):
    return (BOOLEAN, outPropValue, outType, outMap)

Parameters

hObject HANDLE
pSetName STRING
propertyName STRING
outPropValue STRING
outType INTEGER
outMap INTEGER

Version

Availability: from Vectorworks 2018