VS:IFC GetPsetProp

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function gets the value of the selected property of the selected pset.

FUNCTION IFC_GetPsetProp(
hObject  : HANDLE;
inStrPsetName  : STRING;
inStrPropName  : STRING;
VAR outStrPropValue  : STRING;
VAR outTypeSelect  : INTEGER) : BOOLEAN;
def vs.IFC_GetPsetProp(hObject, inStrPsetName, inStrPropName):
    return (BOOLEAN, outStrPropValue, outTypeSelect)

Parameters

hObject HANDLE
inStrPsetName STRING
inStrPropName STRING
outStrPropValue STRING
outTypeSelect INTEGER

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the pset or property;

Remarks

outTypeSelect – value depends on the property type:

  • 1 – identifier,
  • 2 – double,
  • 3 – boolean,
  • 4 – integer,
  • 5 – number (same as double),
  • 6 – logical,
  • 7 – string,
  • 8 – enu-meration,
  • 9 – select value;

Example

IFC_SetPsetProp(hWall, 'Pset_WallCommon', 'Reference', outValue, iType);

Version

Availability: 2010