VS:IFC GetPsetProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 24: Line 24:
hObject
hObject
HANDLE
HANDLE
 
Handle to object
</line>
</line>
<line>
<line>
inStrPsetName
inStrPsetName
STRING
STRING
 
Name of the pset
</line>
</line>
<line>
<line>
inStrPropName
inStrPropName
STRING
STRING
 
Name of the property
</line>
</line>
<line>
<line>
outStrPropValue
outStrPropValue
STRING
STRING
 
Value of the property
</line>
</line>
<line>
<line>
outTypeSelect
outTypeSelect
INTEGER
INTEGER
 
Type of the property
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the pset or property.
outTypeSelect – value depends on the property type: 1 – identifier, 2 – double, 3 – boolean, 4 – integer, 5 – number (same as double), 6 – logical, 7 – string, 8 – enu-meration, 9 – select value.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 53: Line 60:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
hWall : HANDLE;
outValue : STRING;
iType : INTEGER;
ok : BOOLEAN;
begin
hWall := FSActLayer;
ok := IFC_GetPsetProp(hWall, 'Pset_WallCommon', 'Reference', outValue, iType);
AlrtDialog(Concat(outValue, ', ', iType));
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
hWall = vs.FSActLayer()
ok, outValue, iType  = vs.IFC_GetPsetProp(hWall, 'Pset_WallCommon', 'Reference')
vs.AlrtDialog(outValue + ', ' + str(iType))
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:59, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the value and type of a selected property from a property set

FUNCTION IFC_GetPsetProp(
hObject :HANDLE;
inStrPsetName :STRING;
inStrPropName :STRING;
VAR outStrPropValue :STRING;
VAR outTypeSelect :INTEGER) : BOOLEAN;
def vs.IFC_GetPsetProp(hObject, inStrPsetName, inStrPropName):
    return (BOOLEAN, outStrPropValue, outTypeSelect)

Parameters

hObject HANDLE Handle to object
inStrPsetName STRING Name of the pset
inStrPropName STRING Name of the property
outStrPropValue STRING Value of the property
outTypeSelect INTEGER Type of the property

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the pset or property.

outTypeSelect – value depends on the property type: 1 – identifier, 2 – double, 3 – boolean, 4 – integer, 5 – number (same as double), 6 – logical, 7 – string, 8 – enu-meration, 9 – select value.

Example

VectorScript

PROCEDURE Test;
VAR
	hWall : HANDLE;
	outValue : STRING;
	iType : INTEGER;
	ok : BOOLEAN;
begin
	hWall := FSActLayer;
	ok := IFC_GetPsetProp(hWall, 'Pset_WallCommon', 'Reference', outValue, iType);
	AlrtDialog(Concat(outValue, ', ', iType));
END;

RUN(Test);

Python

hWall = vs.FSActLayer()
ok, outValue, iType  = vs.IFC_GetPsetProp(hWall, 'Pset_WallCommon', 'Reference')
vs.AlrtDialog(outValue + ', ' + str(iType))

Version

Availability: from Vectorworks 2014