VS:IFC GetPsetName

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function gets the name of the Pset at specified index.

FUNCTION IFC_GetPsetName(
hObject  : HANDLE;
inPsetIndex  : INTEGER;
VAR outStrPsetName  : STRING) : BOOLEAN;
def vs.IFC_GetPsetName(hObject, inPsetIndex, RETURN):
    return outStrPsetName

Parameters

hObject HANDLE
inPsetIndex INTEGER
outStrPsetName STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, index out of range;

Remarks

Use this function in conjunction with IFC_GetNumPsets. If inPsetIndex = 1, the function will return the name of the first pset, attached to the object.

Example

IFC_GetPsetName(hObject, 1, outStrPsetName);

Version

Availability: 2010